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1. FR CUBE-At a Glance
Overview
Congratulations for purchasing a FR CUBE In-System Programmer.
The FR CUBE Series of In-System Programmers are a breakthrough in
the Programming industry. The programmers support a large number of
devices (microcontrollers, memories, CPLDs and other programmable
devices) from various manufacturers and have a compact size for easy ATE/
fixture integration. They work in standalone or connected to a host PC (RS232, LAN and USB connections are built-in), and are provided with easy-touse software utilities

.
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Features

Support of microcontrollers, serial and parallel memories, CPLDs
and other programmable devices
High-speed, parallel programming
Compact size (fixture friendly)
Standalone operations or host controlled
Designed for easy ATE interfacing
Robust and reliable
Support of several programming interfaces (JTAG, BDM, SPI, I2C,
UART, etc.)
Large built-in internal memory for projects, images, etc.
Programmable power supply output (1.5-13V)
Programmable I/O voltage (1.6-5.5V)
High-speed I/O
USB, LAN (isolated), RS-232 (isolated) and low-level interface (isolated)
ISP I/O relay barrier (only available on the single-site model)
I/O protection
Wide range power supply (12-25V)

The shortest possible programming times are guaranteed due to a
combination of highly optimized programming algorithms, local storage of
programming data and high slew rate line driver circuitry.

10
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Model Comparison
The following table summarizes the main features of the various FR CUBE
family models.

FR CUBE Model Comparison

Feature

FR CUBE GP02

FR CUBE GP04

FR CUBE GP08

2
12-25V

4
12-25V

Device Type Support

Microcontrollers,
CPLDs, Serial
Memories

Microcontrollers,
CPLDs, Serial
Memories

Programming
Protocols

UART, SPI, JTAG,
I2C, BDM, SWD,
etc.

UART, SPI, JTAG,
I2C, BDM, SWD,
etc.

8
12-25V
Microcontrollers,
CPLDs, Serial
Memories, Parallel
Memories
UART, SPI, JTAG,
I2C, BDM, SWD,
etc.

Relay Barrier

No

No

No

1.6-5.5V
100mV
12
2

1.6-5.5V
100mV
24
4

1.6-5.5V
100mV
48
8

1.5-15V
100mV
2

1.5-15V
100mV
4

1.5-15V
100mV
8

Yes
Yes, 100Mbit/s
Yes, Full Speed

Yes
Yes, 100Mbit/s
Yes, Full Speed

Yes
Yes, 100Mbit/s
Yes, Full Speed

General Features
Programming Sites
Power Supply

ISP Lines
Adj. Voltage Range
Adj. Voltage Resolution
Bidirectional Lines
Prog. Clock Out Lines

Programmable Power Supply (PPS)
Range
Resolution
Channels
Host Interface
RS-232 (Isolated)
LAN (Isolated)
USB

Low-Level Interface
(Isolated)

START,
START,
START,
START_ENA[1..2],
START_ENA[1..4],
START_ENA[1..8],
PASS/FAULT[1..2],
PASS/FAULT[1..4],
PASS/FAULT[1..8],
BUSY, PRJ_SEL[0..5] BUSY, PRJ_SEL[0..5] BUSY, PRJ_SEL[0..5]
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Package Checklist
The FR CUBE package includes the following items:
1.
2.
3.
4.
5.
6.

FR CUBE unit.
15V power supply.
Serial and USB cables.
FR CUBE test board.
48-way, female wire-wrap DIN41612 connector.
Software CD.

Connectors Overview

FR CUBE has several connectors for interfacing to a host PC, to an
Automatic Test Equipment (ATE), and to the target system(s) to be
programmed. The following pictures show where, depending on the model,
the various connectors are located.
FR CUBE GP 02/04

1.
2.
3.
4.
5.

12

FR CUBE GP 08

The POWER connector accepts a DC voltage between 12V and 25V.
The USB connector, LAN, and RS-232 connectors are used to
interface the instrument to a PC.
The ETH RESET push button is used to reset LAN settings to their
factory settings.
The ISP connector(s) are used to interface to the target system(s)
to be programmed.
The LOW-LEVEL INTERFACE connector is used to interface
the instrument to an ATE or other systems.
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For details and pinout of the various connectors, see the “Connectors”
chapter on page 59.

LEDs
The LEDs on the top cover of the instrument, from top to bottom, indicate:
1.
2.
3.
4.

POWER: the instrument is turned on.
STATUS: indicates system warnings. Normally off, blinks if the
system needs user action (to retrieve detailed error information,
see “Status Commands” on page 34)
BUSY: turns on when programming (when a programming
project is being executed).
PASS/FAULT: result of programming. Each programming site has an
PASS/FAULT LED, which turns green if programming on that site has
been successful, red otherwise.
FR CUBE GP02 LEDs

FR CUBE GP04 LEDs

FR CUBE GP08 LEDs

PWR ON

PWR ON

PWR ON

STATUS

STATUS

STATUS

BUSY

BUSY

BUSY

S1 PASS

FAULT

S1 PASS

FAULT

S1 PASS

FAULT

S2 PASS

FAULT

S2 PASS

FAULT

S2 PASS

FAULT

S3 PASS

FAULT

S3 PASS

FAULT

S4 PASS

FAULT

S4 PASS

FAULT

S5 PASS

FAULT

S6 PASS

FAULT

S7 PASS

FAULT

S8 PASS

FAULT
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Programming Drivers and Licenses
FR CUBE comes with preinstalled programming drivers (algorithms) that
support common microcontrollers and memories. When you purchase a
new programming driver, you are supplied with a new driver file (.wnd) and
an updated license file (.wnl). The license file enables the use of all of your
purchased drivers on your specific FR CUBE unit.
You must copy these files to the unit’s internal memory: the driver file must be
copied to the unit’s \drivers folder, and the license file to the unit’s \sys folder.
Please refer to “FR CUBE File System” on page 53 for more information.

14
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Guided Tutorial
The following tutorial will guide you through the steps required to set up
your FR CUBE programmer and create your first programming project.

1.

Install Software

2.

Launch the Project Generator

Insert the Setup CD into your PC and install the FR CUBE
software.

Launch the Project Generator application, that is located under
Programs > Systein > FR CUBE Software > Project Generator.

15

Getting Started

3.

Create a New Project

4.

Create a New Project, Step 1 of 3

2

Select File > New Project, give a name to your programming
project, and then follow the Project Creation Wizard steps.

In the first Wizard step, specify the target device, by clicking the
“Edit” button.

Next, specify the file to be programmed (image file). To create an
image file, click the “Create/Edit File” button. A dedicated
window will open.

16
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In the Output File section, specify the output filename by clicking
the “...” button.
Use the “Add” button to compose the data that will compose the
Image file. Use the “...” button to specify the name of the Image
file. When done, click “OK” to return to the Wizard, and proceed
to Step 2.

5.

Create a New Project, Step 2 of 3

In this step, specify target parameters and connection values. The
Wizard will automatically fill all data with typical values for the
selected target device.

17
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The number of tabs displayed in this window depends on the selected
target device; however, three tabs (“Target I/O”, “Target Power Supply”
and “Communication”) are always present and will be briefly discussed
below.
The first tab is “Target I/O”. The “Device I/O voltage” setting specifies
the voltage of the ISP lines. You should check the target board schematics,
or ask the board developer about this value. The allowed voltage also
depends on the selected target device.
The “Clock I/O drive mode” setting allows you to decide how the SxL04
ISP line is driven (the x index refers to the programming site; see “ISP
Connectors” on page 59). This line can be used as an auxiliary ISP line (to
provide a clock to the target device), as a generic I/O line, or as a highimpedance output (no electrical driving). When used as output line (set to
high or low), it could be used, for example, to disable the external watchdog
circuit in the target board. When used as clock out, you can specify the
output frequency in the “Clock I/O frequency” field. We suggest leaving
this line floating (HiZ) when not used, in order to decrease electrical noise on
other ISP lines.

18
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If you decide to power the target board through the FR CUBE power supply
line (SxPPS), specify in the “Target Power Supply” tab the electrical and
timing parameters of the target power supply line. FR CUBE is able to
power the target board through a dedicated programmable power supply
output line per site. The voltage of the programmable power supply line
(“Target power supply voltage” setting) can be in the range 1700mV
to 13000mV. Each programmable power supply line features an internal
voltage limiter that cuts the voltage output in case of short circuits or
overloads. The current output is limited to about 400mA.
The “Power up time” setting specifies the delay between the
programmable power supply line turning on and the first operation on the
ISP lines. The purpose of this parameter is to wait for the power supply to
become stable, before starting ISP programming. This parameter is useful
when large capacitors are mounted in the target board’s power line.
The “Power down time” setting acts in similar way: it sets the delay
between the programmable power supply line turning off and subsequent
operations.

19
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The content of the “Communication” tab depends on the selected target
device. It allows you to select the communication protocol that will be
used for programming (some target devices may provide more than one
communication protocol) and its related settings, usually the communication
speed and other parameters. Usually, the higher the communication speed,
the shorter/better the ISP cabling must be.
After carefully checking all of the parameters values, proceed to Step 3.

20
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6.

Create a New Project, Step 3 of 3

In this step you select which programming operation to perform
on the target.

2

Click “Finish” to end the Wizard. At this point, a FR CUBE
Programming Project will be created in the \Projects directory,
relative to the Project Generator application location.

21
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7.
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Configure your FR CUBE Instrument

Choose Project > Select FR CUBE Model, and specify your
FR CUBE model and communication settings with the PC.
Currently, FR CUBE can be connected only through a serial port.
FR CUBE communicates at 115,200 bps by default.
LAN and USB connections will be supported soon through a free
software upgrade.
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8.

Connect to Target Device

Connect FR CUBE to your target system through the ISP
connector(s). To view the connections for your selected target
device, select Debug > Show ISP Connections.

See the table on page 60 for more details
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9.

Startup FR CUBE

10.

Program the Target Device

Connect FR CUBE to your PC through the provided serial cable.
Finally, power up FR CUBE using the provided power supply.

Select Debug > Run Project. The Project file (.wnp) and Image
file (.wni) will be automatically uploaded to FR CUBE and the
project will be executed. Your target device(s) will be
programmed.

In case of programming errors, or to change programming parameters/
operations, you can relaunch the Project Wizard and review the project
settings.

24
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Manual Project Editing
The Project file created by the Project Wizard is located, by default, in the
\Projects directory, relative to the Project Generator application location
(this location can be changed by specifying a different “workspace” path:
to do so, in the Project Generator, select Project > Edit Miscellaneous
Settings and modify the Workspace setting).
The generated project file is a text file and, if necessary, can be edited using
any text editor. Please note, however, that once the file is modified by the
user, it can be opened by the Project Generator but the Project Wizard will
not be available.

Where to Go from Here
In this chapter, you have learnt how to use the Project Generator to create
and execute a typical programming project. Additionally, FR CUBE can be
controlled in three other ways:
1.
2.
3.

By manually sending commands and receiving answers, using
the Project Generator Terminal or any other terminal application
(for more information, see “Commands” on page 27);
By configuring the instrument so that it can work in standalone,
that is without a connection to a PC (for more information, see
“Standalone Mode” on page 39);
By building your own PC software that interfaces to the instrument 		
(for more information, see “FR CUBE API” on page 43).

25
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3. Commands
Overview
FR CUBE is a slave unit and is always awaiting for a new command
incoming from the master (PC).
When the programmer receives a SOF (Start Of Frame) character (#),
indicating the start of a new command, it loads all incoming characters
in a buffer until the reception of the return character (\n, ASCII code h0A).
Maximum command length is 256 characters.
After reception of the return character, the programmer interprets and
executes the received command; depending on the execution of the
received command the protocol will answers to the master in three different
ways.
1.
2.
3.

If the command is correctly executed, the programmer answers
with an OK frame.
If the command execution generates errors, the programmer
answers with an ERR frame.
If the command takes long to execute, the programmer
periodically answers with a BUSY frame, until command
execution is over and an OK or ERR frame is answered.

All commands and answers are case-insensitive.

27
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Command Syntax
A FR CUBE command begins with the SOF character (#), followed by the
command name, followed by zero or more command switches, and ends
with the return character (\n).
This is an example of a FR CUBE valid command:

3

#status -o ping{\n}

OK Answer

An OK answer is composed of zero or more characters, followed by
the > character, followed by the return character (\n).
This is an example of a FR CUBE OK answer:
pong>{\n}

ERR Answer

An ERR answer is composed of zero or more characters (usually the
hexadecimal error code), followed by the ! character, followed by the return
character (\n).
This is an example of a FR CUBE ERR answer:
h40000103!{\n}

BUSY Answer

A BUSY answer is sent by the programmer to the PC if a command take
some time to execute. A BUSY answer is sent at most every 3 seconds.
If no OK, ERR or BUSY answer is sent within 3 seconds from the last
command sent to the programmer, a communication error has probably
occurred.
A BUSY answer is composed of zero or more characters, followed by
the * character, followed by the return character (\n).
This is an example of a FR CUBE BUSY answer:
*{\n}

A valid answer always ends with two characters: >{\n}, !{\n} or
*{\n}, depending on whether an OK, ERR or BUSY frame is sent
to the host. Additional return characters (\n) may be present in
the answer, but they don’t signal the end of the answer.

28
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FR CUBE Terminal
Commands can be sent (and answers received) using any terminal
application. For your convenience, the Project Generator application
includes a Terminal window that will simplify the communication with the
instrument. Just select Tools > FR CUBE Terminal to open the Terminal
window.

3
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Command Reference
The following pages list all of the FR CUBE commands, grouped by
function, together with their syntax and usage examples.

3

Data In/Out Commands
Syntax
#data –o set –c <direction> -t file –f <filename>
#data –o set –c <direction> -t volatile

Parameters
<direction>
<filename>

in or out.

Filename on the instrument’s file system.

Description
Specify the source and destination of the programming data.
Examples
Sets the input image file to be programmed, and subsequently programs it:
#data -o set -c in -t file -f \images\myfile.wni
>
#prog -o cmd -c program -m flash -s h8000 -t h8000 -l h8000
>

Sets the output file to receive binary data, and subsequently reads data
from the target device:
#data -o set -c out -t file -f \images\dump.bin
>
#prog -o cmd -c read -m flash -s h8000 -t h8000 -l h8000
>

30
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Execution Command
Syntax

#exec -o prj -f <project> -s <sites>

Parameters
<project>
<sites>

The Project filename to execute.
A 8 bit value indicating the programming sites to be enabled.

Description
Executes the specified Project over the specified programming sites.
In case of error, a 32 bit value is returned. This value indicates whether the
error is site-specific (bit 29 = 1) or system-specific (bit 29 = 0). If the error
is site-specific, the 8 least significant bits (bits from 7 to 0) signal whether
programming in the corresponding programming site (bit 7 = programming
site 8, bit 0 = programming site 1) was successful (bit = 0) or not (bit = 1).
To retrieve error messages, use the #status –o get -p err -v <site> -l <errlevel>
command, where <site> is 1 to 8 to retrieve a specific programming site
error, or 0 to retrieve a system error. <errlevel> is the error detail information
that is returned and can be 1, 2, 3.
Examples
Executes the Project “myprj.wnp” on programming sites 1, 2, 3, 4:
#exec –o prj –f \projects\myprj.wnp -s h0f
h20000003!

In this case, the returned error indicates that there are site-specific errors
(bit 29 = 1) and that the sites where errors occurred are sites 1 and 2.
To retrieve detailed error information about site 1, for example, the following
command can be sent:
#status –o get -p err -v 1 -l 2
h5000001,23,”Error: Timeout occurred”
>

The answers indicates that Project line 23 issued a h5000001 error, and the
text between quotes explains the error.

31
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File System Commands
Syntax

3

#fs –o rmdir –d <directory>
#fs –o mkdir –d <directory>
#fs –o dir –d <directory>
#fs –o del –f <filename>
#fs –o send –d <filename>
#fs –o receive –d <filename>

Parameters
<directory>
<filename>

Full path of a directory.
Full path of a filename.

Description
Allow to perform various operations on the programmer’s file system.
Examples
Shows the contents of the programmer’s root directory:
#fs –o dir –d \
2010/06/21 16:35:06
2010/06/21 16:35:16
2010/06/21 16:35:20
2010/06/21 16:35:26
>

32

[DIR]
[DIR]
[DIR]
[DIR]

projects
sys
images
drivers
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Programming Commands
Syntax
#load –l <driver> -m <manufacturer> -d <device>
#dev –o begin
#dev –o end
#dev –o set –p <parameter> -v <value>
#conf –o begin
#conf –o end
#conf –o set –p <parameter> -v <value>
#prog –o begin
#prog –o end
#prog –o cmd –c pps -v <pps value>
#prog –o cmd –c connect
#prog –o cmd –c disconnect
#prog –o cmd –c unprotect
#prog –o cmd –c erase –m <mem type> -t <tgt addr> -l <len>
#prog –o cmd –c blankcheck –m <mem type> -t <tgt addr> -l <len>
#prog –o cmd –c program –m <mem type> -s <src addr> -t <tgt addr> -l <len>
#prog –o cmd –c verify –v <ver mode> –m <mem type> -t <tgt addr> -l <len>
#prog –o cmd –c read –m <mem type> -s <dst addr> -t <tgt addr> -l <len>

3

Parameters
<driver>
<manufacturer>
<device>
<parameter>
<value>
<pps value>
<mem type>
<tgt addr>
<len>
<src addr>
<ver mode>
<dst addr>

Filename of the .wnd driver.
Target device’s silicon manufacturer.
Target device code.
Target parameter to set.
Value of the corresponding parameter.
on or off.
Target memory type.
Target start address.
Data length.
Source (buffer) start address.
Verify mode: read or chks.
Destination start address.

Description
Perform various programming settings and operations on the target device.

33
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Status Commands
Syntax
#status –o ping
#status –o get –p err –v <site> –l <errlevel>

3

Parameters
<site>
<errlevel>

1 to 8 to get programming site errors. Use 0 to return system errors.
1 to 3.

Description
Get instrument status or error information.
When retrieving error information, one or more error lines (depending on
the <errlevel> parameter) are returned. Each line begins with a 32-bit code,
which codifies the following information:
Bit 31:
Bit 30:
Bit 29:
Bit 28:
Bit 27:
Bits 26 to 24:
Bits 23 to 0:

34

Reserved
If 1, an error message in text format is available.
If 1, the error is programming site specific.
If 1, the error is driver (programming algorithm) specific.
If 1, the error is a system fatal error.
Reserved.
Error code. If bit 29 is 1, then bits 7 to 0 signal whether
programming in the corresponding programming site (bit
7 = programming site 8, bit 0 = programming site 1) was
successful (bit = 0) or not (bit = 1).
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Examples
Pings the instrument to check if communication is OK:
#status –o ping
pong>

Retrieves the last generated errors, on programming site 1, with different
error levels:

3

#status -o get -p err -v 1 -l 1
H50000023
>
#status -o get -p err -v 1 -l 2
H50000023,71,”Connection Error.”
>
#status -o get -p err -v 1 -l 3
H50000023,71,”Connection Error.”,”algo_api”,337
H10000000,71,””,”st701_cmds”,432
H10000000,71,””,”st701_entry”,287
H10000000,71,””,”st701_icc”,208
H10000001,71,””,”hal_icc1”,144
>

35
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System Commands
Syntax

3

#sys –o set –p br –v <baud rate>
#sys –o get –p br
#sys –o get –p sn
#sys –o get –p ver –v <code>
#sys –o set –p lliop –s <prj sel> -f <prj filename>
#sys –o get –p lliop –s <prj sel>

Parameters
<baud rate>
<code>
<prj sel>
<prj filename>

9600, 19200, 38400, 57600, 115200, or 230400.
sys or driver.

Project number, as selected by the PRJ_SEL[5..0] lines
on the Low-Level Interface connector.
Project file associated to <the prj sel> setting.

Description
Set or get instrument’s internal parameters.
Examples
Sets a new serial baud rate:
#sys -o set –p br –v 115200
>

Retrieves the instrument’s serial number:
#sys -o get -p sn
00100>

Associates the project test.wnp to the project number 1:
#sys –o set –p lliop –s 1 -f \projects\test.wnp
>
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Time Commands
Syntax
#time –o set –p date –d <date>
#time –o set –p time –d <time>
#time –o get –p date
#time –o get –p time

3

Parameters
<date>
<time>

A date in the format yyyy/mm/dd.
A time in the format hh:mm:ss.

Description
Set or get the instrument’s date and time. Once set, the date and time are
maintained even when the instrument is powered off.
Examples
Sets the date/time to February 1st, 2011, at noon:
#time –o set –p date –d 2011/02/01
>
#time –o set –p time –d 12:00:00
>

Retrieves the instrument’s date and time:
#time –o get –p date
2011/02/01>
#time –o get –p time
12:02:05>
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Volatile Memory Commands
Syntax
#volatile –o write –s <site> -a <start address> - l <len> -d <data>
#volatile –o read –s <site> -a <start address> - l <len>

3

Parameters
<site>
<start address>
<len>
<data>

Programming site. 1 to 8 to set specific site data, 0 to set
the same data for all sites.
Volatile memory starting address.
Data length.
A data array.

Description
Read and write data from/to the instrument’s volatile memory.
Examples
Uses the volatile memory on site 1 to store the target board’s MAC address:
#volatile –o write –s 1 -a h0 -l 6 -d [h00 h90 h96 h90 h48 h85]
>

Retrieves data from site 1 volatile memory:
#volatile -o read -s 1 -a h0 -l 6
1,[h00 h90 h96 h90 h48 h85]>
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4. Standalone Mode
Overview
FR CUBE can work with no connection to a PC (standalone mode).
In standalone mode, the instrument is controlled through a low-level
connection interface.

4

Signals
Signals needed to control the instrument in standalone mode are located
in the “Low-Level Interface” connector (see “Connectors” on page 59 for
the connector pinout on the various FR CUBE models) and are explained
below.
Signal level is 0-5V. All lines are isolated (referenced to GNDI).
Define which project to execute (see
“Project Assignment” later on this
chapter).
START_ENAx lines (input): Select which programming site(s) to enable.
Active low.
START line (input):
Executes the project specified by
PRJ_SELx lines on the programming
site(s) enabled by START_ENAx lines.
Active low.
BUSY line (output):
Indicates that a project is being executed.
Active high.
PASS/FAULTx lines (output): Valid at the end of project execution (when
BUSY is low). Indicate, for each programming
site(s), the success state of the programming
project. (OK = high, ERR = low).
PRJ_SELx lines (input):
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Standalone Mode
The following diagram illustrates the timing for the Low-Level Interface signals.

PRJ_SELx
PRJ_SELx and START_ENAx lines are sampled at the START falling edge,
and must remain stable until BUSYrising edge

START_ENAx

START

4

BUSY
OK/ERRx lines become valid at the
BUSY falling edge

OK/ERRx

Previous state

New state

Low-Level Interface Signals Timing
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Project Assignment
Before working in standalone mode, you must associate PRJ_SELx lines to
a Project filename to execute.
To do so, in the FR CUBE Project Generator application select
Project > Hardware Settings. In the window that will appear, associate
PRJ_SEL values to project names by clicking the “Set Project” button for
each PRJ_SEL configuration you wish you setup.

4
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5. FR CUBE API
Overview
You can build your own PC software that interfaces to the instrument, by
using the provided FR CUBE Application Programming Interface (API). The
FR CUBE API consists of a series of functions, contained in the fr_comm
DLL, which allow you to set up and control the programmer.
The fr_comm DLL is located in the \Developer folder, relative to the
FR CUBE software installation path. In the same folder you can find the
source code of sample applications, in various programming languages,
that use the fr_comm DLL.
Additionally, a command line application (fr_cmds.exe) is provided, which
reads a programming command from the stdin, sends the command to the
instrument, and writes the command answer on the stdout.

Including the API in Your Application
To use the FR CUBE API, you must:
Include the “fr_comm.lib” and “fr_comm_lib.h” files in your
application project (only needed for Visual C++ projects);
Copy the “fr_comm.dll” file in the same folder of your
application executable (this file must also be redistributed with
your application).
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FR CUBE API
The typical program flow for interfacing with FR CUBE is the following:

1. Open communication (FR_OpenCommPort()function)

2. Execute commands(FR_ExeCommand()function)

3. Transfer files to/from the instrument’s internal memory
(FR_SendFile()andFR_ReceiveFile()functions)

5

4. Close communication(FR_CloseCommPort()function)

Function Reference
API functions are listed and explained alphabetically in the following pages.
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FR_CloseCommPort()
Prototype
FR_COMM_ERR WINAPI FR_CloseCommPortA (FR_COMM_HANDLE handle);
FR_COMM_ERR WINAPI FR_CloseCommPortW (FR_COMM_HANDLE handle);

Description
Closes the communication channel with the instrument.
Return Value
0
!=0

5

The function call was successful.
The function call was unsuccessful.
Call the FR_GetLastErrorMessage() function to get error
information.

Parameters
handle

Communication handle returned by the
FR_OpenCommPort() function.
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FR_ExeCommand()
Prototype
FR_COMM_ERR WINAPI FR_ExeCommandA (FR_COMM_HANDLE handle, const
char *command, char *answer, unsigned long maxlen, unsigned long timeout_ms,
FR_ANSWER_TYPE *type);
FR_COMM_ERR WINAPI FR_ExeCommandW (FR_COMM_HANDLE handle, const
wchar_t *command, wchar_t *answer, unsigned long maxlen, unsigned long timeout_
ms, FR_ANSWER_TYPE *type);

Description

5

Executes a FR CUBE command. This function automatically sends a
command to the instrument and returns the answer read back from the
instrument. This function combines the FR_SendFrame() and FR_GetFrame()
function in a single call.
Return Value
0
!=0

The function call was successful.
The function call was unsuccessful.
Call the FR_GetLastErrorMessage() function to get error
information.

Parameters
handle
command
answer
maxlen
timeout_ms
type

46

Communication handle returned by the		
FR_OpenCommPort() function.
A valid FR CUBE command.
The answer read back from the instrument in response
to the command sent.
Maximum length, in characters, of the answer buffer.
Time (in milliseconds) before the function times out.
Type of answer received: can be:
FR_ANSWER_ACK (an OK frame was received);
FR_ANSWER_NACK (an ERR frame was received);
FR_ANSWER_TOUT (command timed out before an
answer could be received).
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FR_GetFrame()
Prototype
FR_COMM_ERR WINAPI FR_GetFrameA (FR_COMM_HANDLE handle, char *answer,
unsigned long maxlen, unsigned long timeout_ms);
FR_COMM_ERR WINAPI FR_GetFrameW (FR_COMM_HANDLE handle, wchar_t
*answer, unsigned long maxlen, unsigned long timeout_ms);

Description
Reads the answer to the command sent by the FR_SendFrame() function.

5

Return Value
0
!=0

The function call was successful.
The function call was unsuccessful.
Call the FR_GetLastErrorMessage() function to get error
information.

Parameters
handle
answer
maxlen
timeout_ms

Communication handle returned by the
FR_OpenCommPort() function.
The answer read back from the instrument in response
to the command sent.
Maximum length, in characters, of the answer buffer.
Time (in milliseconds) before the function times out.
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FR_GetLastErrorMessage()
Prototype
void WINAPI FR_GetLastErrorMessageA (char *error_msg, unsigned long tring_len);
void WINAPI FR_GetLastErrorMessageW (wchar_t *error_msg, unsigned long string_
len);

Description
Returns a string containing the last FR CUBE error message.

5

Parameters
error_msg
msg_len
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The string that will receive the error message.
Length, in characters, of the error message buffer.
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FR_ReceiveFile()
Prototype
FR_COMM_ERR WINAPI FR_ReceiveFileA (FR_COMM_HANDLE handle, const char
*protocol, const char *src_filename, const char *dst_path, bool force_transfer, FR_
FileTransferProgressProc progress);
FR_COMM_ERR WINAPI FR_ReceiveFileW (FR_COMM_HANDLE handle, const
wchar_t *protocol, const wchar_t *src_filename, const wchar_t *dst_path, bool force_
transfer, FR_FileTransferProgressProc progress);

Description
Receives a file from the instrument’s internal memory and saves it to the
PC.

5

Return Value
0
!=0

The function call was successful.
The function call was unsuccessful.
Call the FR_GetLastErrorMessage() function to get error
information.

Parameters
handle
protocol
src_filename
dst_path
force_transfer
progress

Communication handle returned by the
FR_OpenCommPort() function.
Transfer protocol. Must be “ymodem”.
The full filename, including path, of the remote file.
The PC path where to store the file.
If TRUE, file transfer will be executed even if a file with
the same name and CRC exists on the PC; if FALSE,
file transfer will be executed only if necessary.
Address of a callback function that will receive progress
information, or 0 if not used.
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FR_SendFile()
Prototype
FR_COMM_ERR WINAPI FR_SendFileA (FR_COMM_HANDLE handle, const char
*protocol, const char *src_filename, const char *dst_path, bool force_transfer,
FR_FileTransferProgressProc progress);
FR_COMM_ERR WINAPI FR_SendFileW (FR_COMM_HANDLE handle, const wchar_t
*protocol, const wchar_t *src_filename, const wchar_t *dst_path, bool force_ transfer,
FR_FileTransferProgressProc progress);

Description

5

Sends a file to the instrument’s internal memory.
Return Value
0
!=0

The function call was successful.
The function call was unsuccessful.
Call the FR_GetLastErrorMessage() function to get error
information.

Parameters
handle
protocol
src_filename
dst_path
force_transfer
progress
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Communication handle returned by the 		
FR_OpenCommPort() function.
Transfer protocol. Must be “ymodem”.
The source full filename.
The remote instrument file system path where to store
the file.
If TRUE, file transfer will be executed even if a file with
the same name and CRC exists on the instrument;
if FALSE, file transfer will be executed only if necessary.
Address of a callback function that will receive progress
information, or 0 if not used.
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FR_SendFrame()
Prototype
FR_COMM_ERR WINAPI FR_SendFrameA (FR_COMM_HANDLE handle, const char
*command);
FR_COMM_ERR WINAPI FR_SendFrameW (FR_COMM_HANDLE handle, const
wchar_t *command);

Description
Sends a command to the instrument. Use the FR_GetFrame() function to
retrieve the answer.

5

Return Value
0
!=0

The function call was successful.
The function call was unsuccessful. Call the
FR_GetLastErrorMessage() function to get error information.

Parameters
handle
command

Communication handle returned by the 		
FR_OpenCommPort() function.
A valid FR CUBE command.
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FR_OpenCommPort()
Prototype
FR_COMM_HANDLE WINAPI FR_OpenCommPortA (const char *com_port, const char
*com_settings);
FR_COMM_HANDLE WINAPI FR_OpenCommPortW (const wchar_t *com_port, const
wchar_t *com_settings);

Description

5

Opens a RS-232, Ethernet or USB communication channel with the
instrument.
Return Value
>0
NULL

alid communication handle to use in subsequent
functions.
The function call was unsuccessful. Call the
FR_GetLastErrorMessage() function to get error information.

Parameters
com_port
com_settings
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Communication port. Can be “COM”, “LAN” or “USB”.
RS-232 settings for “COM” port (e.g.: ”COM1,115200”);
Ethernet settings for “LAN” port (e.g.: ”192.168.1.100:2101”);
Empty string for “USB” port.
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6. FR CUBE File System
Overview
FR CUBE has a large, built-in non-volatile memory, used to store the various
files required by the instrument: programming projects, image files, etc.
This memory is organized by a file system. You can explore the FR CUBE
files either by using a Terminal application and sending file-system related
commands, or (more simply) by using the File Manager window of the
Project Generator application. The File Manager window allows you to easily
see the instrument file structure and transfer files with the PC. To open the
File Manager, choose Tools > FR CUBE File Manager from the Project
Generator menu.
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FR CUBE File System

File System Structure

The files required by the instrument are organized in various folders, as
explained below:
\drivers folder: contains programming algorithms (.wnd files).
These files are provided by Systein.
\sys folder: contains systems files, such as programming licenses,
firmware files, etc.
These files are provided by Systein.
\project folder: contains programming projects (.prj files).
You create programming projects using the Project Generator
application.
\images folder: contains FR CUBE image files to be
programmed to the target (.wni files).
FR CUBE image files contain all the information needed to
program a target device memory. These files are created by the
Project Generator application.

6
You can create additional folders, but the four folders listed
above must always be present on the FR CUBE file system and
must not be removed. Additionally, do not remove or rename
the contents of the \SYS folder.
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7. Variable Data Programming
Overview
FR CUBE has built-in, dedicated memory banks for each programming
site. This memory can be used to temporarily store variable data that will
be written to the target device during programming. This is useful for serial
numbering and for any other variable data that needs to be written to the
target device at programming time.

Usage
To implement variable data programming:
1.

Use the Project Creation wizard of the Project Generator
application to create your programming project. When creating
the FR CUBE Image file, add a variable data record to the output
file, as shown below.

7
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Variable Data Programming
2.

You will then be asked for the target device address range to
be programmed and the offset of the memory bank that will
contain the variable data.

3.

Proceed to the end of the Project Creation wizard. Your
programming project is now ready to accept variable data.
Before executing the project, you must supply the variable data
to each of the programming sites.
To do so, send the #volatile –o write command (for more information, 		
see “Volatile Memory Commands” on page 38).

4.

7

Alternatively, you can skip steps 1 to 3, but you must manually edit your
programming project by inserting an appropriate #data –o set –c out -t volatile
command and subsequent appropriate programming commands (for more
information, see “Data In/Out Commands” on page 30).
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8. Power and Relay Options
Power Supply Options
FR CUBE can be powered in two ways:
1.
2.

With the provided power supply (which supplies 15V DC);
By providing a power supply to the PWR pin of the
Low-Level Interface connector (see “Low-Level Interface 			
Connector” on page 60).

Relays
On all FR CUBE models, a special signal (SxRLY) is present (on the “ISP”
connector), on every programming site. If the programming site is enabled,
this signal is driven to 0V when a #relay –o close command is executed, and
driven to 5.5V when a the #relay –o open command is executed).
This is useful for driving an external relay barrier.
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9. Connectors
ISP Connectors
FR CUBE GP02 PASS and FR CUBE GP04 PASS models have one ISP
connector; the FR CUBE GP08 PASS model has two ISP connectors.

FRC_GP_02 ISP Connector

FRC_GP_04 ISP Connector

9

FRC_GP_08 ISP Connectors
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A5
A6
A7
A8
B5
B6
B7
B8
C5
C6
C7
C5

A1
A2
A3
A4
B1
B2
B3
B4
C1
C2
C3
C4

Brown

Red

Orange

Yellow

Green

Blue

Purple

Grey

White

Black

S2

C12

C11

C10

C9

B12

B11

B10

B9

A12

A11

A10

A9

S3

C16

C15

C14

C13

B16

B15

B14

B13

A16

A15

A14

A13

S4

ISP Connector A
Sites

9
S1

Color

C4

C3

C2

C1

B4

B3

B2

B1

A4

A3

A2

A1

S5

C5

C7

C6

C5

B8

B7

B6

B5

A8

A7

A6

A5

S6

C12

C11

C10

C9

B12

B11

B10

B9

A12

A11

A10

A9

S7

C16

C15

C14

C13

B16

B15

B14

B13

A16

A15

A14

A13

S8

ISP Connector B
Sites

SxGND

SxRLY

SxPPS

SxL07

SxL06

SxL05

SxL04

SxL03

SxL02

SxL01

FR
Signal
Name

ISP Signal Definitions

RLY - Relay Output

GND - GND

VDD - Target VDD (Programmer can provide a
power supply for the target system)

#HOLD - Hold (programmer set to inactive level
while programming the device)

DI(IO0) - Serial Data Input

#S - Chip select

CLOCKOUT

DO(IO1) - Serial Data Output

CLK - Serial Clock

#W - Write Protect (programmer set to inactive
level while programming the device)

Target Signal Description

Connectors
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Low-Level Interface Signals
FR CUBE GP02
Pin

FR CUBE GP04
Pin

FR CUBE GP08
Pin

Input Power Supply (12-25V)
Power Supply Ground

A5/B5
C5

A5/B5
C5

A5/B5
C5

GNDI

Low-Level Interface Ground

A10/B12/
C15/C16

A10/B12/
C15/C16

A10/B12/
C15/C16

TX_RS232
RX_RS232

RS-232 TX (Output)
RS-232 RX (Input)
Project Selector 0 (Input, internal
pull-up)
Project Selector 1 (Input, internal
pull-up)
Project Selector 2 (Input, internal
pull-up)
Project Selector 3 (Input, internal
pull-up)
Project Selector 4 (Input, internal
pull-up)
Project Selector 5 (Input, internal
pull-up)
Project Start (Input, internal
pull-up)
Site 1 Project Start Enable (Input,
internal pull-up)
Site 2 Project Start Enable (Input,
internal pull-up)
Site 3 Project Start Enable (Input,
internal pull-up)
Site 4 Project Start Enable (Input,
internal pull-up)
Site 5 Project Start Enable (Input,
internal pull-up)
Site 6 Project Start Enable (Input,
internal pull-up)
Site 7 Project Start Enable (Input,
internal pull-up)
Site 8 Project Start Enable (Input,
internal pull-up)
Busy (Output, push-pull)
S1 PASS/FAULT (Output, push-pull)
S2 PASS/FAULT (Output, push-pull)
S3 PASS/FAULT (Output, push-pull)
S4 PASS/FAULT (Output, push-pull)
S5 PASS/FAULT (Output, push-pull)
S6 PASS/FAULT (Output, push-pull)
S7 PASS/FAULT (Output, push-pull)
S8 PASS/FAULT (Output, push-pull)

A16
B16

A16
B16

A16
B16

B10

B10

B10

C10

C10

C10

A11

A11

A11

B11

B11

B11

C11

C11

C11

A12

A12

A12

A7

A7

A7

B7

B7

B7

C7

C7

C7

-

A8

A8

-

B8

B8

-

-

C8

-

-

A9

-

-

B9

-

-

C9

C12
A13
B13
-

C12
A13
B13
C13
A14
-

C12
A13
B13
C13
A14
B14
C14
A15
B15

Signal

Description

PWR
GND

PRJ_SEL0
PRJ_SEL1
PRJ_SEL2
PRJ_SEL3
PRJ_SEL4
PRJ_SEL5
START
START_ENA1
START_ENA2
START_ENA3
START_ENA4
START_ENA5
START_ENA6
START_ENA7
START_ENA8
BUSY
PASS/FAULT1
PASS/FAULT2
PASS/FAULT3
PASS/FAULT4
PASS/FAULT5
PASS/FAULT6
PASS/FAULT7
PASS/FAULT8

9
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All low-level interface lines are isolated from system GND (and
are referenced to GNDI), except for the PWR line, which is
referenced to GND.

Ground Domains
The following diagram illustrates the two ground domains of the
programmer.

ATE and Target Ground Domains

9

In order to avoid undesired current paths between the
programmer and the target board, we suggest to use a power
supply with a floating output (ground not referenced to the
Earth potential).
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10. Specifications
Electrical Specifications
Feature
Maximum Ratings
Power supply voltage
ISP SxL0[1..7] voltage
ISP SxL0[1..7] current
ISP SxPPS voltage
ISP SxPPS current(*)
ISP SxRLY voltage
Low level interface PRJ_SELx, START,
START_ENAx, BUSY, PASS/FAULTx
voltage
Operating Ranges
Power supply voltage
ISP SxL0[1..7] voltage
ISP SxPPS voltage
ISP SxPPS current
ISP SxRLY voltage
Low level interface PRJ_SELx, START,
START_ENAx, BUSY, PASS/FAULTx
voltage
Physical and Environmental
Operating conditions
Storage conditions
EMC (EMI/EMS)

Value
30V
-0.7-6.5V
±60mA
-0.7-18V
380mA
-1.0-30V
-0.7-6.0V

12-25V
0-5.5V
1.5-15V
300mA
0-28V
0-5.0V

0-40°C, 90% humidity max (without
condensation)
-10-60°C, 90% humidity max (without
condensation)
CE, FCC

(*) Current limited, recovers automatically after fault condition is
removed.
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ISP Connectors
ISP and Low-Level Interface connectors are DIN48 male connectors.
We suggest using the following compatible female connectors.
For wire wrapping:
DIN41612 connector, 3 rows, 48 pins, 180° female, C style
Manufacturer: Conec
Manufacturer Part Number: 122A10619X
Catalog Part Number: Mouser 706-122A10619X
For soldering:
DIN41612 connector, 3 rows, 48 pins, female, R/A C style
Manufacturer: FCI
Manufacturer Part Number: 86093488613755E1LF
Catalog Part Number: Mouser 649-8693488637E1L

10
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